Date Picker Not Working In Wordpress Widget

Availability calendars and inventory control
Post Reply
georgeiv
Posts: 1
Joined: Wed Jun 13, 2018 1:58 am

Date Picker Not Working In Wordpress Widget

Post by georgeiv » Wed Jun 13, 2018 2:16 am

Hi Guys :)

The date selector for wordpress plugin is no longer working. When a user tries to pick a date, a red circle with a line through it appears over the date hover and they are also unable to select dates in the future from the widget strip.
Wordpress and associated plugins are up to date. I have deactivated each plugin to see if it is causing the conflict but there was no change. This is only a new error. Previously the plugin worked fine. For reference example, please visit the booking strip here https://www.georgeiv.com.au/accommodation/

Thanks in advance,

Claire

annettemorgenroth
Posts: 920
Joined: Sun Jun 30, 2013 8:44 am

Re: Date Picker Not Working In Wordpress Widget

Post by annettemorgenroth » Wed Jun 13, 2018 7:09 am

I can not recreate your problem. This is what I see when trying to book on your web site: http://recordit.co/5BBr8e4fId

Which browser are you using?

stonelion
Posts: 25
Joined: Tue Feb 13, 2018 12:29 pm

Re: Date Picker Not Working In Wordpress Widget

Post by stonelion » Tue Jun 19, 2018 1:54 am

I'm able to replicate the problem in both chrome and firefox.

The circle with a diagonal line through the circle shows up if you mouse over the date input text box. The circle indicator only goes away if the mouse pointer is directly above the calendar icon. Anywhere else in the white text box input and the circle indicator shows up.

If you click on the calendar icon, the pop-up window shows dates for the month of July with no next/prev arrows to scroll back and forth between months. It's definitely broken.

markkinchin
Site Admin
Posts: 894
Joined: Fri Mar 02, 2012 1:43 pm

Re: Date Picker Not Working In Wordpress Widget

Post by markkinchin » Tue Jun 19, 2018 8:25 am

Something is adding "read only" status to the date picker input boxes, this is causing them to be un-selectable

Have you added anything or changed your theme recently, it must be something else on the page doing this.

Post Reply